Back to overview
Degraded
Timeouts on QC Linux and CE Applications
Dec 12 at 10:08pm PST
Affected services
Dragon
Resolved
Dec 12 at 10:25pm PST
We have identified the root cause of the incident as coming from a large burst of queries by a small number of Qualcomm users. The query burst has subsided and the application has recovered.
We are actively working to improve our rate limiting logic to protect the availability of the service in these cases. Additionally, we are continuing to monitor usage and application health to prevent the issue from recurring.
Affected services
Created
Dec 12 at 10:08pm PST
We are observing timeouts occurring on the QC Linux and CE applications. We are investigating the issue and will update as our investigation progresses.
Affected services