Back to overview
Degraded

Degraded performance

Mar 31, 2025 at 01:01am UTC
Affected services
Dragon

Resolved
Mar 31, 2025 at 01:27am UTC

Incident resolved.

Updated
Mar 31, 2025 at 01:11am UTC

Incident has been mitigated but our on-call teams are continuing to monitor.

Created
Mar 31, 2025 at 01:01am UTC

Degraded performance. On-call team is investigating.